Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Connect AirNav Pro IOS to Prepar3d V4

Martijn Oct 28, 2018 03:11PM CET

Hi,

I need some help to connect AirNavPro in my Ipad with Prepar3d v4.
So far I have done the following:

I have followed the steps in the user manual exactly as indicated.
- Downloaded the Prepar3d v4 plugin from your website.
- Installed the plugin in the Prepar3d directory as administrator

When I start up P3D I find the Xample AirNavBridge in the top menu. I click it to activate the bridge.
When I check the status it says:
"Xample Airnav Bridge v2.0.0.1
Status: Active"

In AirNavPro on my Ipad I have activated the MS Flight Simulator X sensors and deactivated all others.
My PC and Ipad are both on the same network.
In the AirNav Pro app I can see the sensors blinking orange and red.
No flight information from Prepar3d is being received.

I have done the following troubleshooting:

- Checked the P3D DLL.exe file for the AirNav entry (Confirmed)
- Checked the P3D DLL file for any typing errors (as suggested in het Help-article)
- Checked the registry for:

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\Microsoft Games\\Microsoft Flight Simulator X\\fsx.exe"="$ IgnoreFreeLibrary<AirnavbridgeFSX.dll> HIGHDPIAWARE"

But I don't have it

- Checked if Bonjour is installed (Confirmed)
- Uninstalled Bonjour, and re-installed the latest version.
- Checked firewall settings and added an outbound rule for Prepar3D and Bonjour

Unfortunately nothing I tried has solved the issue.

Can you please help me out?

thanks!


Up 0 rated Down
Martijn Oct 28, 2018 10:23PM CET
Additionally...I’m not sure if this is relevant but I did manage to set up the Webserver and a WebDAV connection.

Thanks for your help!
Up 0 rated Down
Oliver Oct 30, 2018 10:31AM CET Xample Agent
Hi Martijn,

thanks for your message in our support forum. We are sorry you are having this issue with our App.

Have you tried to restart the app (double tap on Home button, swipe the app up and open it again) after activating the bridge on P3D?

Cheers

Oliver Maiwald
Xample Sàrl

Follow us and stay up to date about all new upcoming features, tools and other news about Air Navigation:

Facebook: https://www.facebook.com/AirNavigationApp
Twitter: https://twitter.com/AirNavPro
Up 0 rated Down
Martijn Oct 30, 2018 12:30PM CET
Hi Oliver,

Thank you for your reply and suggestion.
I have tried it several times but unfortunately I can’t get the connection between P3D and AirNavPro pro.

While trying your suggestion I noticed that the sensors in the app initially are red.
As soon as I click ‘Activate bridge’ in Prepar3D the sensor start blinking orange/ red
So there seems to be some kind of connection but not good enough to make the sensors switch to green.

Kind regards,

Martijn
Up 0 rated Down
Martijn Nov 01, 2018 11:46AM CET
Hi,

Okay, I have come one step closer to a solution.
I have noticed that the connection between P3D and Airnavpro works when I disable the firewall on my computer.

Can you tell me if there is a certain setting I need to apply in my firewall?

thanks!

Martijn
Up 0 rated Down
Martijn Nov 01, 2018 12:52PM CET
Solved!

Apparently the Firewall rule I added for Prepar3d was not properly activated. I should have paid more attention.

Maybe it's usefull for somebody else in the future.

Kind regards,

Martijn
Up 0 rated Down
Oliver Nov 15, 2018 06:36PM CET Xample Agent
Hi Martjin,

thanks for your messages.

Glad the issue could be solved.

Best regards

Oliver

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Contact Us

  • Post in the public forum
  • Your message can be read and responded by either a support agent or anyone else in the forum.
  • Email Us
  • Your message will be private and only a support agent will be able to see it and respond it.

Tutorials

  • Video tutorials (iOS)
  • Videos showing how to use some of the features in Air Nav Pro. ONLY for the iOS version available.

Notifications

  • Facebook page
  • Follow us to get news about updates, improvements, new maps and products regarding Air Nav.
help@xample.ch
https://cdn.desk.com/
false
assistly
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete